Technologies numériques/Découpe laser/Graphique vectoriel- Intermédiaire
Contexte
Cet article fait suite à l'article « Les bases du graphique vectoriel », qui démontrait comment utiliser Inkscape, un éditeur de graphique vectoriel, pour préparer vos fichiers avant d'utiliser les découpeuses laser au Makerspace.
Dans « Graphique vectoriel intermédiaire », vous découvrirez d'autres fonctionnalités d'Inkscape qui peuvent améliorer vos créations et vous inspirer de nouvelles idées pour vos projets.
Par exemple comment utiliser les extensions et des fonctionnalités prédéfinies faciles à intégrer à votre création avec un minimum de modifications et aussi comment modifer individuellement une création grâce à l'outil Nœud.
Inkscape est une plateforme sans limites, et cet article vise à vous aider à identifier les fonctionnalités souvent inutilisées qui pourraient propulser votre création vers un niveau supérieur.
Les Extensions
Les extensions intégrées sur Inkscape peuvent simplifier la conception et ajouter plus de fonctionnalités dans le logiciel. Inkscape propose un grand nombre d'extensions à des fins diverses. Par exemple, pour créer un objet rond ou incurvé, vous pouvez utiliser l'extension "Living Hinge",les charnières vivantes . Voici un exemple :
Elles sont facilement accessibles depuis la barre d'outils Extensions, illustrée ci-dessous. D'autres extensions créées par la communauté Inkscape peuvent être facilement téléchargées de la galerie d'extensions Inkscape accessible en ligne, ici.
Comment installer une extension?
Pour installer une extension, suivez les étapes suivantes :
1. Téléchargez et décompressez le fichier d'archive depuis le site web.
2. Choisissez l'emplacement de copie de ces fichiers :
Dans Inkscape, allez sur: Édition(Edit) ->Préférences(Preferences) ->Système (System) ->Extensions utilisateur (User Extensions).
3. Localisez ce chemin d'accès sur votre ordinateur et copiez les deux fichiers téléchargés (fichiers .inx et .py).
4. Redémarrez Inkscape. Vous devriez désormais pouvoir accéder l'extension depuis la barre d'outils des extensions.
Les Extensions d'Inkscape
Une fois téléchargées, vous trouverez les extensions dans Inkscape, qui pourraient alors être utilisés dans différents projets. La charnière vivante est une des extensions la plus fréquemment utilisée.
Charnières vivantes
Une charnière vivante est une partie flexible d'un objet qui permet le mouvement entre deux segments. Elle s'obtient en créant une série de lignes fines découpées, permettant ainsi à l'objet de se plier sans se casser. Au lieu de créer plusieurs lignes à vectoriser, ce qui peut être monotone, voir un gaspillage de temps, vous pouvez utiliser l'extension Inkscape disponible en allant dans Extension->Rendu(Render)->Charnière vivante(Living hinge).
Autres extensions
D'autres extensions sont disponibles en téléchargement ici. Elles vont des boîtes découpées au laser aux puzzles, en passant par les formes, les engrenages, les calendriers et bien plus encore.
L'outil Nœud
L'outil Nœud permet de manipuler librement un objet et ses éléments. C'est un outil puissant qui permet d'ajuster les nœuds individuels d'un objet plutôt que l'objet dans son ensemble. La vidéo suivante présente comment fonctionne l'outil Nœud et son utilité lors de la conception.
La relation entre la couleur d'un motif et la puissance du laser
Les couleur des différentes parties d'un motif est un autre facteur qui contribue à rendre la gravure plus foncée ou plus claire. Lors de la création d'un motif, vous pouvez utiliser la fonction "Remplissage"(Fill) d'Inkscape pour ajouter de la couleur.
L'utilisation des couleurs foncées, comme le noir, produira une image plus sombre une fois gravée, contrairement à des couleurs plus claires. Voici un exemple :
Le motif ci-dessus est composé du même texte rempli de quatre couleurs différentes. Une fois gravé, le résultat obtenu est présenté ci-dessous:
Les couleurs plus foncées ont donné une gravure plus sombre que la précédente, dont le remplissage était plus clair. Par conséquent, pour une gravure plus foncée, il est généralement recommandé d'utiliser le noir comme couleur de conception.
De plus, on peut également noter que les trois premiers textes ne présentent pratiquement aucune différence avec le dernier. Les couleurs plus foncée produisaient un résultat similaire. Il est essentiel de choisir des couleurs avec des nuances qui sont très différentes comme par exemple le noir et le blanc, pour les dessins comportant de nombreux éléments, afin d'obtenir une image nette et contrastée après la gravure. Les dessins comportant beaucoup de détails, comme les cartes du monde, nécessitent un bon contraste pour être clairement visibles, d'où le besoin d'utiliser des couleurs aux nuances très différentes.
Les motifs
Au lieu de créer des formes similaires de manière répétitive, pour créer un motif, vous pouvez utiliser la fonctionnalité de "motif"(pattern) d'Inkscape, ainsi, vous ne perdez pas de temps et vous raffinez votre conception.
- Une fois que vous ayez votre conception, accédez à Remplissage et Contour (Fill and Stroke) -> Remplissage et sélectionnez l'icône de motif (entourée de jaune dans l'image ci-dessous).
2. Sélectionnez le motif de votre choix et utilisez les paramètres à droite (entourés de rouge) pour ajuster sa position.
Vous pouvez également créer un motif à partir de vos images préférées au lieu de celles disponibles dans Inkscape.
Pour faire cela, suivez les étapes ci-dessous:
- Placez l'image que vous souhaitez utiliser comme motif sur l'espace de travail. Vous pouvez également créer votre propre objet à l'aide des outils d'Inkscape.
- Cliquez sur l'image, puis accédez à Objet(Object) > Motif(Pattern) > Objets à motif(Object to Pattern). Le motif est créé et vous pouvez le retrouver en accédant à l'icône de motif dans la section Style de Remplissage ou de Contour (Fill or Stroke style).
3. Pour utiliser votre motif, placez la forme souhaitée, puis accédez à l'icône Remplissage-> Motif et ajustez le motif à la perfection.
Vous pouvez désormais créer vos propres motifs et créer des designs uniques pour vos prochains projets.
Les filtres
Les filtres[1] permettent d'améliorer des formes simples en ajoutant des textures réalistes et en donnant plus de style à votre création. Inkscape propose un grand éventail de filtres, allant de l'effet peau de lézard à l'effet perlé. L'image suivante montre comment accéder aux filtres et démontre quelques exemples.
Fonctionnalités du texte
Personnalisation du texte[2]
Grâce à l'outil Nœud, vous pouvez facilement manipuler les différentes lettres de votre texte et varier leur position, leur forme et même leur couleur.
Une fois votre texte écrit, sélectionnez-le et accédez à Chemin (Path) -> Objet vers chemin (Object to Path).
Assurez-vous que l'outil Nœud, situé sous l'outil Sélecteur, à gauche, est sélectionné.
Vous pourrez ensuite sélectionner individuellement les nœuds présents et ajuster le texte. La vidéo suivante montre comment utiliser l'outil Nœud :
Insérer le texte sur un chemin
Au lieu d'avoir un texte sur une ligne droite, vous pouvez utiliser « Créer un chemin » et faire en sorte que votre texte suive ce chemin.
1.Dessinez un chemin et votre texte sur le même document, sélectionnez les deux et accédez à « Texte », situé sur la ligne supérieure.
2.Sélectionnez "Insérer sur un chemin" (Put on path)
Votre texte suivra le chemin que vous avez tracé :
Paramètres de traçage
Décalage de ligne
Décalage dynamique pour les contours de formes
Le décalage dynamique dans Inkscape permet de décaler un tracé ou une forme pour créer un contour, une bordure ou un encart.
La vidéo suivante montre comment utiliser le décalage dynamique dans Inkscape et l'effet qu'il apporte à un dessin.
Tracer une image bitmap
Pour pouvoir vectoriser une image obtenue en ligne, il faut d'abord la convertir en bitmap, c'est-à-dire la transformer en une carte de pixels que la tête laser peut suivre pour une gravure. Plus l'image est simple, meilleurs seront les résultats. Il existe différents principaux types de modes de détection, à savoir:
1.Seuil de luminosité (Brightness Cut-off) :
Le plus le seuil est élevé, le moins le nombre de pixels considérés comme « blancs » sera élevé et l’image deviendra alors plus sombre.
2.Détection de contour (Edge Detection) :
Produit une image bitmap qui ressemblera moins à l'image d'origine par rapport au seuil de luminosité, mais fournira des informations sur la courbe.
3.Quantification des couleurs (Color Quantization) :
Identifie les contours où les couleurs changent, même à luminosité et contraste égaux.
La vidéo suivante explique comment utiliser la fonctionnalité "Tracer un bitmap" dans Inkscape et les différents modes de détection possibles.
La fonctionnalité "Tracer le bitmap" est accessible soit en faisant un clic droit sur l'image et en sélectionnant Tracer le bitmap, comme illustré dans la vidéo, soit en sélectionnant Chemin -> Tracer le bitmap:
Importer depuis un logiciel de CAO
Au lieu de concevoir un projet dans Inkscape, vous pouvez également importer un fichier depuis un logiciel de CAO.
Si vous utilisez Onshape, par exemple, faites un clic droit sur le croquis et sélectionnez "Exporter au format DXF/DWG".
Une boîte de dialogue s'affichera, vous invitant à choisir entre DXF et DWG. Dans cet exemple, DXF R14 (version 14) est sélectionné.
Cliquez sur "Exporter" une fois le format choisi.
Ouvrez le fichier dans Inkscape. La boîte de dialogue suivante apparaîtra :
Sélectionnez « Lire à partir du fichier » pour vous assurer que le dessin dans Inkscape a les dimensions exactes du dessin CAO. Vous pourrez ensuite modifier la largeur du trait pour spécifier si vous souhaitez une découpe ou une gravure.
Vous pouvez enregistrer le fichier au format SVG pour toute modification ultérieure, puis au format PDF pour l'envoyer à une découpe laser.
Vous pouvez également utiliser un convertisseur DXF/DWG vers SVG en ligne pour convertir un fichier CAO en fichier compatible Inkscape.
- Pour les dessins SolidWorks, suivez les étapes de la vidéo ci-dessous :
- Pour Fusion 360 vers Inkscape, suivez les étapes de la vidéo ci-dessous :